Diagnosing general technical issues

Try pressing Ctrl+F5 on the webpage and then repeat the action
If this works the issue was hopefully a temporary one and it has already been resolved.

If your browser has a “Private Browsing” mode enable this and repeat the action in this new window.
  • Ctrl+Shift+N (Chrome)
  • Ctrl+Shift+P (IE/Firefox)
  • Safari -> Private Browsing (Safari)
If this works then it is likely an addon you have installed on your browser, please consider returning to non private mode and then disabling them one at a time while retesting the issue

Try a different browser (Chrome ideally, or Firefox if you are already using Chrome). If you are using a mobile device and have access to a full PC, please try it on this.
If this works then the issue is likely caused by the browser you are using, please try upgrading to the latest one available and checking the FAQ for specific guidance relating to your browser.

If you have been unable to fix the issue by following these steps, please contact us with the results.
  • Include a full series of steps to replicate the issue (even if it appears to affect all e.g. full record links, please pick a particular one which doesn't work and let us know how you get to this one).
  • Take a screenshot of where the issue occurs (unless it contains sensitive information please try to take it of the whole screen rather than cropping into the error).
  • Tell us details of what device you are using e.g. Firefox browser on Windows 10, or iPhone on iOS 8

I found this helpful
I did not find this helpful

Didn't find what you were looking for? Feel free to call or send us an email